Myaccount service problem
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Jul 09, 2019 - 15:40 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 09, 2019 - 11:36 PDT
Monitoring
The sign-in problem affecting Myaccount was resolved. Please contact Biola IT at 562-903-4740 if you continue to experience problems accessing any web-based Biola services.
Posted Jul 09, 2019 - 10:28 PDT
Update
We are continuing to investigate this issue.
Posted Jul 09, 2019 - 09:52 PDT
Investigating
The Myaccount sign-in page is loading slowly and not allowing some users to log in at all. IT is aware of the problem and investigating now.
Posted Jul 09, 2019 - 09:51 PDT
This incident affected: Academic Services (My Account).