Canvas service degradation
Incident Report for Biola University
Resolved
Instructure has resolved the problem with Canvas.
Posted Mar 03, 2021 - 14:32 PST
Investigating
Canvas is loading slowly for some users. Instructure has acknowledged the problem and is working on a solution.

https://status.instructure.com/
Posted Mar 03, 2021 - 13:46 PST
This incident affected: Academic Services (Canvas Learning Management System).