Urgent Confluence Security Update
Incident Report for Biola University
Resolved
Confluence has been updated and services have been restored.
Posted Apr 18, 2019 - 11:35 PDT
Identified
Confluence is undergoing an urgent security update to patch a vulnerability identified by the vendor. Service should be restored before noon.
Posted Apr 18, 2019 - 09:53 PDT