Network restoration in progress after campus power outage
Incident Report for Biola University
Resolved
Our technician has restored network/internet services to all of the affected campus locations. Thanks again for your patience, and please contact the IT Helpdesk at 562.903.4740 with any remaining questions about this outage and service restoration.
Posted Jan 17, 2019 - 02:42 PST
Identified
Our technician has restored network/internet services to the following campus locations:
Blackstone
Beachcomber
Hope
Lido
La Mirada Apartments
Rancho Campus
Tradewinds
Tropicana

We are still investigating service outages at the following locations:
Alpha Even
Cafe
Emerson
Horton
Posted Jan 17, 2019 - 00:14 PST
Investigating
A number of campus buildings are still without network connectivity as a result of the campus-wide power outage. A technician is on campus working to restore network/Internet service to the following buildings – thank you for your patience:
Alpha Even
Beachcomber
Blackstone
Cafe
Emerson
Hope
Horton
Lido
La Mirada Apartments
Rancho Campus
Tradewinds
Tropicana
Posted Jan 16, 2019 - 22:20 PST
This incident affected: Network (Wired Network, Wireless Network).