Printing outage
Incident Report for Biola University
Resolved
IT has resolved the campus printing outage. If you have questions about the outage, please contact the IT Helpdesk at 562-903-4740 or it.helpdesk@biola.edu.
Posted Feb 14, 2019 - 12:15 PST
Investigating
Biola is experiencing a print service outage. IT is investigating the problem and working to resolve it. We will provide an update when more information is available.
Posted Feb 14, 2019 - 11:41 PST
This incident affected: Campus Services (Printing (Pharos)).