Google Calendar Service Disruption
Incident Report for Biola University
Resolved
Google has resolved the problem with the Google Calendar.
Posted Jun 18, 2019 - 12:33 PDT
Investigating
Google Calendar is experiencing a service disruption that has affected many Biola users. Google is aware of the problem and is working to resolve it. You can see real-time updates from Google about the status of their services here:
https://www.google.com/appsstatus
Posted Jun 18, 2019 - 11:53 PDT
This incident affected: Google Apps (Calendar).