Calls not completing to Health Center, Nursing, and Bookstore
Incident Report for Biola University
Resolved
All the 3 voice menu numbers are now working. Inbound calls are getting their respective voice call menus.
Posted Sep 14, 2020 - 11:02 PDT
Investigating
Voice Menus for the Health Center, Nursing and the Bookstore are not picking up incoming calls after last Friday evening’s maintenance. Technicians are investigating.
Posted Sep 14, 2020 - 09:20 PDT
This incident affected: Campus Services (Telephones).