Self-Service password reset system down
Incident Report for Biola University
Resolved
The problem with the self-service password reset system was resolved.
Posted Jan 07, 2021 - 14:18 PST
Investigating
Biola's NetID password reset is currently down. If someone attempts to email a password reset link to themselves it will not work. To reset your password, please contact the IT Helpdesk at it.helpdesk@biola.edu or call ext 4740 and we will manually email you a password reset.
Posted Jan 07, 2021 - 13:34 PST
This incident affected: Administrative Services (Password Reset).