Biola Directory Service Disruption
Incident Report for Biola University
Resolved
Biola IT has restored the search feature of the Biola Directory.
Posted Jun 18, 2019 - 12:18 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 18, 2019 - 12:14 PDT
Identified
The Biola Directory search feature is not functioning correctly. IT has identified the problem and is working to correct it.
Posted Jun 18, 2019 - 12:09 PDT
This incident affected: Campus Services (Biola Directory).