Inside Story down for unscheduled maintenance
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Dec 04, 2018 - 10:30 PST
Investigating
We are currently investigating a problem with Inside Story and have put the site in maintenance mode while we troubleshoot. We will post updates as they are available.
Posted Dec 04, 2018 - 10:11 PST