Verizon cellular calls failing
Incident Report for Biola University
Resolved
The Verizon cellular calling issue has been resolved. Our phone circuit provider confirmed that services were restored early this morning, and our testing with Campus Safety confirms that calls which were previously failing are now completing successfully. This service impact has concluded.

For assistance with any Biola technology service please contact the IT Helpdesk by email (it.helpdesk@biola.edu), phone (562) 903-4740, or chat. To view the status of Biola systems and subscribe for maintenance updates please visit https://status.biola.edu/.
Posted Apr 10, 2019 - 09:58 PDT
Update
Verizon has moved some of their wireless services to an alternate path as they continue to repair their fiber optic cable. Our tests indicate that Verizon cellular service is not fully restored. We will continue to monitor the situation and provide updates as we receive them.
Posted Apr 09, 2019 - 16:57 PDT
Identified
IT received an update from Level 3 that a fiber-optic cable was cut somewhere between Barstow and Bakersfield, California. Level 3 states that the problem with Verizon wireless calls not getting through may be related to this fiber cable repair. We are reaching out to clients to provide updates about this issue.
Posted Apr 09, 2019 - 15:19 PDT
Update
IT placed a ticket with Level3/Century Link to troubleshoot samples calls made from Verizon mobile phones to (562) 903-6000. Some of our test calls from Verizon cell phones are already beginning to get through to the Campus Safety Communications Center. We will update again once the issue is fully resolved.
Posted Apr 09, 2019 - 15:02 PDT
Investigating
We have received a report that Verizon cell phone calls to the university are failing with an automated message saying welcome to Verizon wireless, and that the number is unavailable. It has been reported that other providers (T-Mobile, Sprint) are able to reach the Biola number. We will investigate.
Posted Apr 09, 2019 - 13:58 PDT
This incident affected: Campus Services (Telephones).