Canvas Outage

Incident Report for Biola University

Resolved

Canvas is operational.
Posted May 08, 2026 - 08:16 PDT

Investigating

Instructure has reported a Canvas outage and is currently investigating the issue.
Posted May 07, 2026 - 13:47 PDT
This incident affected: Academic Services (Canvas Learning Management System).