Biola's earthquake early warning system offline

Incident Report for Biola University

Resolved

This issue has been resolved and the USGS ShakeAlert system is online again. Thanks for your patience.
Posted Mar 17, 2025 - 09:45 PDT

Investigating

Due to a security incident the USGS has taken ShakeAlert offline. Biola's earthquake early warning system will be offline until this issue is resolved. We will advise once the USGS resolves this issue.
Posted Mar 14, 2025 - 11:53 PDT
This incident affected: Campus Services (Earthquake Early Warning System).