Wireless Connectivity Issues

Incident Report for Biola University

Resolved

The wireless connectivity issues have been resolved. The guest portal is now available, and normal service has been restored for all networks. Thank you for your patience.
Posted Sep 17, 2026 - 13:34 PDT

Investigating

We are currently experiencing connectivity issues with the Guest wireless network and are actively investigating connection problems affecting the Biola-NetID network. IT is working to restore full service as quickly as possible. We will provide updates as more information becomes available.
Posted Sep 17, 2026 - 13:04 PDT
This incident affected: Network (Wireless Network).