Phishing Alert!

Incident Report for Biola University

Resolved

If you clicked on the link and submitted any information in response to any of the recent phishing email attacks, please take the following steps immediately:

1. Change your Biola Microsoft account Password
2. Check your Google Account for Unauthorized Activity
3. Set Up Microsoft Authenticator for MFA
4. Remove Your Mobile Phone Number as a form of MFA

Need assistance, contact the IT Service Desk.
Posted May 06, 2025 - 12:18 PDT

Monitoring

Biola IT has identified and responded to two separate phishing attacks sent to Biola email accounts today:

1. FAKE ACCOUNT TERMINATION EMAIL
This message falsely claimed your Biola email account was scheduled for deletion and urged you to click a link to “verify your account.”

2. FAKE “DEAR STAFF/STUDENT” JOB OFFER
Another scam offered fake part-time job opportunities, often using subject lines like “Dear Staff/Student” and promising high pay for minimal work.

If you clicked on the link or submitted any information in response to the recent phishing email please contact the IT Service Desk.
Posted May 05, 2025 - 11:57 PDT
This incident affected: Google Apps (Gmail).