Touchnet Payment
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 08:31 PDT
Investigating
Touchnet Payment is not connecting to Banner at this time. We are currently investigating with the vendor.
Posted Mar 12, 2020 - 07:41 PDT
This incident affected: Campus Services (Billing and Payment (TouchNet)).