VPN service issues reported by some users
Incident Report for Biola University
Resolved
This issue has been resolved.
Posted Jun 22, 2020 - 10:49 PDT
Investigating
Some users are reporting connection problems with Biola's VPN. Biola IT is investigating.
Posted Jun 22, 2020 - 08:45 PDT
This incident affected: Network (VPN).