Directory search is experiencing a service degradation
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Sep 16, 2019 - 16:37 PDT
Update
The Directory search issue has been resolved. All service are functioning normally.
Posted Sep 16, 2019 - 16:37 PDT
Identified
Searching in the Web Directory may not return all search results. This issue has been identified and a resolution is in progress.
Posted Sep 16, 2019 - 16:22 PDT
This incident affected: Campus Services (Biola Directory).