Scan to Email

Incident Report for Biola University

Resolved

Scan to email is now working on campus Bizhubs and HP copiers. If you experience and trouble, please open a Request Help ticket.
Posted Sep 29, 2025 - 08:29 PDT

Update

We are continuing to investigate this issue.
Posted Sep 10, 2025 - 15:21 PDT

Investigating

The scan-to-email service on Biola copiers is currently unavailable. We’re working to restore functionality as soon as possible.
Posted Sep 09, 2025 - 16:46 PDT
This incident affected: Campus Services (Print and copy (PrinterLogic)).