Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 19, 2025 - 06:30 PDT
Scheduled
On Thursday, June 19 at 6:30 AM, Information Technology will apply an emergency security patch to a key system that manages access to IT applications and services. This maintenance will take place for approximately 15 minutes.
During this time, access to several services—including the Biola website, My Account, and Banner—will be temporarily unavailable. Access to cloud-hosted applications will not be affected.
Posted Jun 18, 2025 - 19:27 PDT
This scheduled maintenance affected: Biola Websites (Main Biola Website, Biola LEARN), Administrative Services (Banner, Cognos, Perceptive Content (ImageNow), Filemaker Pro Database Hosting), Campus Services (Biola Directory, eAccounts, ID Card Services, Timecard, Transact), and Academic Services (My Account, Add/Drop, Enrollment Tasks).