ID Card Printing
Incident Report for Biola University
Resolved
ID card printing services have been restored and the service is fully functional.

For more information please see this service page: https://services.biola.edu/TDClient/75/Portal/Requests/ServiceDet?ID=4875
Posted Sep 10, 2024 - 16:19 PDT
Update
ID card printing services have been restored and the service is fully functional.
Posted Sep 10, 2024 - 13:19 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 10, 2024 - 13:17 PDT
Identified
ID card printing services are currently unavailable. The ID Card printer malfunctioned and a service technician is scheduled to repair the printer on Monday September 9.

All other ID Card services are functional (digital Biola IDs, ID Card photo submission services, ID Card Access Readers, etc).

We apologize for any inconvenience and are working to restore this service. Thank you for your patience.
Posted Sep 06, 2024 - 09:40 PDT
This incident affected: Campus Services (ID Card Services).