Myaccount loading slowly
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Nov 09, 2019 - 08:54 PST
Monitoring
A fix has been implemented and is we are now monitoring.
Posted Nov 08, 2019 - 11:16 PST
Investigating
Myaccount pages are loading slowly. IT is aware of the problem and investigating.
Posted Nov 08, 2019 - 10:24 PST
This incident affected: Academic Services (My Account).