my.biola.edu service outage
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 08:23 PST
Investigating
The my.biola.edu site is experiencing an outage. Biola IT contacted our site host, Terminalfour, and we are waiting on them for a resolution.
Posted Feb 13, 2024 - 17:31 PST
This incident affected: Administrative Services (Terminalfour (my.biola.edu)).