Phone System Issue: 10-second delay
Incident Report for Biola University
Resolved
This issue has been resolved. If you are still experiencing a delay when placing an internal call from a Biola phone or Jabber, please report it by contacting the IT Helpdesk at 562.903.4740.
Posted Jul 26, 2021 - 15:59 PDT
Investigating
IT is investigating reports of a 10-second delay when placing some calls. The behavior on a desk phone and Jabber appears to be identical: calls and transfers to internal extensions appear to have a 10 second delay before the calls connect, but calls to outside numbers connect immediately.

We will continue to investigate this issue and resolve it on Monday, July 26.
Posted Jul 23, 2021 - 13:35 PDT
This incident affected: Campus Services (Telephones).