Delayed rollout of new Gmail feature
Incident Report for Biola University
Resolved
The Gmail feature that allows users to write emails and send later is now working. If you cannot see the new feature, clear the cookies and cache on your browser and restart it.

Here are Google's directions for clearing cookies and cache in Chrome: https://support.google.com/accounts/answer/32050?co=GENIE.Platform%3DDesktop&hl=en
Posted Apr 18, 2019 - 09:02 PDT
Investigating
The new Gmail feature that allows users to write an email and send it later is currently not available. Biola IT has reached out to Google to investigate the problem.
Posted Apr 17, 2019 - 09:39 PDT
This incident affected: Google Apps (Gmail).