Biola Learn planned maintenance
Incident Report for Biola University
Resolved
The maintenance for Biola LEARN has been completed. Thanks for your patience!
Posted Sep 24, 2019 - 18:51 PDT
Update
The planned maintenance for Biola LEARN is taking longer than anticipated. We're continuing to work on this and will post another update within the hour.
Posted Sep 24, 2019 - 18:02 PDT
Investigating
Biola Learn is currently undergoing planned maintenance for the next 1 hour.
Posted Sep 24, 2019 - 17:06 PDT
This incident affected: Biola Websites (Biola LEARN).