Pharos system - unwanted duplicate print jobs
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 08:29 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 09, 2024 - 10:28 PST
Identified
Biola IT has identified an issue with the Pharos print and copy system that causes random and unwanted duplication of printouts. Pharos has been unable to resolve the problem. IT is in the process of implementing a new print and copy system called PrinterLogic, which is expected to resolve this issue. In the interim, if you encounter this problem, please create a ticket and we will suspend all future printing charges for your department printer. If affected, consider monitoring print jobs and canceling any unwanted duplicates to prevent wasting paper and toner.

Printing ticket link:
https://services.biola.edu/TDClient/75/Portal/Requests/TicketRequests/NewForm?ID=p-i2wsG4iZE_&RequestorType=ServiceOffering

IT estimates that PrinterLogic will replace Pharos across all department printers and copiers by the end of this calendar year. We will prioritize the PrinterLogic implementation for printers affected by this issue.

Benefits of PrinterLogic:

*Employees can install a printer or copier on their Biola computer using the PrinterLogic web interface --- there is no longer any need to contact IT for assistance.
*IT will no longer charge for print and copy usage; quotas will be applied and can be increased on request.
*Department managers will no longer need to add and remove employees from their printing cost center. All employees, including student workers, will have access to PrinterLogic automatically.
*There will be no changes to how paper and toner are ordered and supplied. Toner is delivered when it is needed; paper is delivered as requested.
*Physically relocating a printer or copier will be accomplished more quickly.
Posted Sep 19, 2023 - 16:50 PDT
This incident affected: Campus Services (Printing (Pharos)).