Campus wide network & phone outage due to power loss
Incident Report for Biola University
Resolved
Campus & phone service is fully restored.
Posted Nov 13, 2019 - 17:59 PST
Update
Crowell Hall, Li Apartments, and the SUB have also been identified as still down.
Posted Nov 13, 2019 - 14:45 PST
Update
All campus buildings have been restored except for Alpha, Blackstone, Crowell, Emerson, Hope, and Rancho Campus. Technicians are working to restore services.
Posted Nov 13, 2019 - 14:35 PST
Monitoring
Campus wireless network, wired network, and phone services are down in most buildings due to the campus power loss. After power restoration our technicians will restore network and voice service.
Posted Nov 13, 2019 - 13:11 PST
This incident affected: Network (Wired Network, Wireless Network) and Campus Services (Telephones).