Phone service disruption
Incident Report for Biola University
Resolved
Phone services are now fully operational. Thank you for your patience.
Posted Jun 19, 2020 - 07:51 PDT
Update
Line forwarding has still not been removed yet, so the main campus line and emergency line are still forwarding to a Dispatch cell phone. All other lines are functioning properly at this time.
Posted Jun 19, 2020 - 00:41 PDT
Monitoring
After both cards were replaced by Frontier techs, both inbound and outbound calling for our voice services (including toll free) is now working once again. CenturyLink is removing the temporary line forwarding and technicians are testing services.
Posted Jun 18, 2020 - 22:34 PDT
Identified
Frontier technicians have identified the failed hardware. They have replaced one failed card and are waiting on the delivery of a second one by another team of technicians. Repairs are in progress.
Posted Jun 18, 2020 - 20:53 PDT
Update
Frontier technicians are on-site working on repairs now.
Posted Jun 18, 2020 - 19:57 PDT
Update
Frontier’s Transport Team arrived on-site with replacement hardware. It appears their replacement hardware is not working and they are looking for working replacement parts.
Posted Jun 18, 2020 - 17:29 PDT
Update
Our local carrier (Frontier Communications) is on-site in Biola’s datacenter now. They have verified that our entire circuit is down and they are enlisting help from Frontier’s Transport Team for escalated assistance.
Posted Jun 18, 2020 - 14:56 PDT
Update
Update: Circuit trouble has been isolated to the local carrier. They are now engaged in investigation and possible repair. We expect to receive a new update within one to two hours per CenturyLink.

Biola's main campus phone number and emergency number have been forwarded to a backup phone line so Campus Safety can still receive calls to the university.
Posted Jun 18, 2020 - 12:27 PDT
Update
Update: Phone services are still down, and troubleshooting is still happening by the carriers. We are awaiting an update from CenturyLink.

User impact: users would see that all inbound and outbound local, toll, and international calling is down, but internal extension calling is up.
Posted Jun 18, 2020 - 11:03 PDT
Investigating
Biola's phone service is down. Calls to and from the campus are failing. Biola IT is working with our phone service provider to resolve the problem.
Posted Jun 18, 2020 - 08:57 PDT
This incident affected: Campus Services (Telephones).