Work has now been completed until the replacement hardware has been received and swapped. For any outstanding issues please open a ticket with the IT Service Desk and we will address accordingly. Thanks again for your patience.
Posted May 18, 2026 - 14:08 PDT
Monitoring
Library update: All services have been restored on Level 1 and Level 3. Critical services are restored on Level 2 including WiFi, security cameras, card readers, Heritage POS, and the IT Service Desk.
Posted May 18, 2026 - 12:30 PDT
Update
Library update: the replacement switch is up, so the 1st & 3rd floors should be up now. We are working on getting WiFi and security cameras up now on the middle level.
Updated ETA for resolution: 11:30 am PDT
Posted May 18, 2026 - 10:55 PDT
Identified
All network services in the Library are currently down due to an equipment failure. Replacement is in process and is estimated to take about 2 hours, restoring service by approximately 10:15 am PDT. We apologize for this inconvenience and thank you for your patience.
Posted May 18, 2026 - 08:19 PDT
This incident affected: Network (Wired Network, Wireless Network).