Windows computers crashing, displaying the Blue Screen of Death, or is unable to reboot
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 12:29 PDT
Monitoring
Crowdstrike pushed out an update to their application that is causing a Blue Screen of Death on Windows Servers and PCs. CrowdStrike is aware of the issue and has rolled back the change.

Biola IT has confirmed that this affected 20 Windows servers -- these Windows servers have all been restored -- but we aren't sure the full impact to our Windows PC environment.

If your Windows computer is crashing, displaying the Blue Screen of Death, or is unable to reboot contract the IT Helpdesk for assistance. The team has instructions on how to remove the the bad CrowdStrike driver and restore your computer.

What is Crowdstrike?
CrowdStrike Falcon Endpoint Detection and Response (EDR) platform is a next-generation cyber security solution that protects our technology environment from malware and malicious attackers.

Crowdstrike Falcon EDR is automatically deployed to all Biola Macs, PCs, and enterprise servers.
Posted Jul 19, 2024 - 05:33 PDT