Calling international numbers through Call Tower currently not available

Incident Report for Biola University

Resolved

In working with our new phone service provider, we have enabled international calling to many countries, including to Brazil, Canada, France, Germany, Hungary, Mexico, Spain, Sweden, Switzerland, Taiwan, Turkey, and the UK, among others. If you experience problems calling a specific country please contact the IT team either at it.helpdesk@biola.edu or 562.903.4740.
Posted Sep 15, 2023 - 16:27 PDT

Investigating

We are currently investigating this issue.
Posted Sep 15, 2023 - 09:15 PDT
This incident affected: Campus Services (Telephones).