Touchnet Payment service outage
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Dec 16, 2023 - 20:56 PST
Investigating
Biola IT is investigating Touchnet Payment Service connection issue from MyAccount at this time.
Posted Dec 16, 2023 - 20:32 PST
This incident affected: Academic Services (Touchnet Payment Service).