Scan to Email Service Down

Incident Report for Biola University

Resolved

Scan to email is now working.
Posted Nov 24, 2025 - 16:40 PST

Investigating

We are currently investigating an issue with Scan to Email service on copiers across the Biola network.
Posted Nov 24, 2025 - 16:11 PST
This incident affected: Campus Services (Print and copy (PrinterLogic)).