Biola Benefits Portal login is not working correctly
Incident Report for Biola University
Resolved
The vendor has resolved the issue with the benefits portal and users can log in again.
Posted Jul 18, 2020 - 19:17 PDT
Identified
The Biola benefits portal (login.biola.edu/benefits) is not working correctly after a system update performed on the evening of 7/16/2020. Users are prompted to set up a username and password even though they've signed in with SSO. We are working with the vendor to come up with a solution.
Posted Jul 17, 2020 - 08:56 PDT
This incident affected: Campus Services (Authentication).