Network Outage for Rose Lower Classrooms and Office of Student Accessibility

Incident Report for Biola University

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 10:45 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2026 - 09:49 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 04, 2026 - 09:22 PDT

Investigating

Technician is investigating hardware fault. Service is available for the rest of campus.
Posted Sep 04, 2026 - 08:45 PDT
This incident affected: Network (Wired Network, Wireless Network).