This incident is closed, but may not be fully resolved. Our carrier is doing everything they can on their end, but there may still be issues for Verizon customers due to Verizon's spam/call blocking policies. Please report any ongoing service issues to IT by submitting a ticket through the IT Service Desk: https://services.biola.edu/TDClient/75/Portal/Home/.
Posted Jul 29, 2025 - 14:02 PDT
Update
We are continuing to investigate this issue.
Posted Jul 14, 2025 - 10:24 PDT
Investigating
Biola is experiencing intermittent outbound calling issues to Verizon Wireless phone numbers. Biola technicians have opened a support case with our calling providers regarding calls from on-premise phones to Verizon numbers coming through as "Blocked-Potential Spam" or being declined. Thank you for your patience.
Posted Jul 14, 2025 - 10:22 PDT
This incident affected: Campus Services (Telephones).