Citrix web client not working properly
Incident Report for Biola University
Resolved
This incident has been resolved.
Posted Oct 06, 2021 - 09:36 PDT
Update
This issue with some apps not opening in the Citrix Workspace client is resolved.
Posted Oct 06, 2021 - 09:36 PDT
Investigating
The citrix.biola.edu web client is not launching applications properly. IT is aware of the problem and working on a solution.

In the meantime, the Citrix Workspace application is still a functioning alternative. Please see our directions on how to use the Citrix Workspace client here: https://confluence.biola.edu/display/itservices/How+to+Run+Citrix+Workspace
Posted Oct 05, 2021 - 12:55 PDT
This incident affected: Administrative Services (Citrix Workspace).