MyAccount to Touchnet payments not working

Incident Report for Biola University

Resolved

This incident has been resolved. If you continue to have trouble making payments in My Account, please contact the IT Helpdesk for assistance. Thanks for your patience!
Posted Nov 06, 2019 - 12:30 PST

Identified

Changes to the Single Sign On authentication service has resulted in a disruption to the connection with the Touchnet Payment service. The root cause has been identified and work on a resolution is currently in progress.
Posted Nov 05, 2019 - 13:47 PST
This incident affected: Campus Services (Billing and Payment (TouchNet)) and Academic Services (My Account).