Alpha Even Network Outage
Incident Report for Biola University
Resolved
The switch has been repaired and wired network service and WiFi have been restored. Thanks for your patience.
Posted Apr 11, 2024 - 20:43 PDT
Investigating
The Alpha Even network switch is down, causing a wired network and WiFi outage on the Even side of Alpha. Technicians are on scene working to repair the problem.
Posted Apr 11, 2024 - 20:00 PDT
This incident affected: Network (Wired Network, Wireless Network).