Users unable to log in to some applications
Incident Report for Biola University
Resolved
If you are still unable to authenticate on web applications like MyAccount and Canvas, clear your browser cache or contact the IT Helpdesk at 562-903-4740.
Posted Apr 06, 2020 - 16:07 PDT
Identified
Issue identified and a fix is in progress.
Posted Apr 06, 2020 - 15:58 PDT
Update
We are continuing to investigate this issue.
Posted Apr 06, 2020 - 15:49 PDT
Investigating
Users unable to log in to some applications including MyAccount and Self Service Banner. Currently under investigation.
Posted Apr 06, 2020 - 15:48 PDT
This incident affected: Campus Services (Authentication).