Web Search is experiencing a service degradation
Incident Report for Biola University
Resolved
This issue has been resolved.
Posted Jan 16, 2020 - 16:23 PST
Investigating
Searching in the Web Directory and Academic Programs may not return all search results. This issue has been identified and a resolution is in progress.
Posted Jan 16, 2020 - 15:49 PST
This incident affected: Biola Websites (Main Biola Website) and Campus Services (Biola Directory).