Banner Admin Page
Incident Report for Biola University
Resolved
Problem has been identified and resolved.
Posted Jul 10, 2019 - 10:08 PDT
Investigating
We are currently investigating an issue with Banner 9 Admin page.
Posted Jul 10, 2019 - 09:33 PDT
This incident affected: Administrative Services (Banner).