Voicemail-to-email service is down
Incident Report for Biola University
Resolved
This incident has been resolved and voicemails-to-email are working again. Thank you for your patience.
Posted Nov 01, 2024 - 10:58 PDT
Investigating
The voicemail-to-email service appears to be failing for all phone system users. We have a support case open with Cisco to seek to restore the service.
Posted Oct 29, 2024 - 09:00 PDT
This incident affected: Campus Services (Telephones).