Azure self-service password reset not functioning
Incident Report for Biola University
Resolved
Biola IT applied the fix to our environment to resolve the Azure Self-Service Password Reset for all faculty, staff, and students.
Posted May 30, 2023 - 18:00 PDT
Identified
Biola IT has identified the likely cause of the disruption with the Microsoft password reset service. IT will begin implementing a solution this week. To reset your password in the meantime, please visit this site: https://apps.biola.edu/accounts/university_account/reset_password_request
Posted Apr 17, 2023 - 20:37 PDT
Update
Biola IT is still working to resolve the problem with the Microsoft password reset service. Please use login.biola.edu to reset your password by visiting: https://apps.biola.edu/accounts/university_account/reset_password_request
Posted Mar 31, 2023 - 15:13 PDT
Investigating
The Microsoft Azure self-service password reset feature is not functioning. In the meantime, to reset your password go to https://apps.biola.edu/accounts/university_account/reset_password_request
Posted Mar 23, 2023 - 17:16 PDT
This incident affected: Administrative Services (Password Reset).